View unanswered posts | View active topics It is currently Thu Nov 23, 2017 7:33 am



Reply to topic  [ 6 posts ] 
 Laney VC15 losing volume help 
Author Message
Promises to use Search button

Joined: Fri Nov 21, 2008 2:13 am
Posts: 7
Post Laney VC15 losing volume help
I have a VC15, I have had it almost a year, it has never left my bedroom and is never moved around. For some reason the amp is now losing it's volume, like half or so. I accidentally left it on for 4 days one time but other than that, there has never been anything wrong with it.
I used to get a great volume on 2 or 3 but now it is low, also if I do not turn it on for a few days the amp will come on at normal volume and then the volume goes down to the quieter volume after about 10 minutes.

Could this be the power tubes? I thought the tubes would last for 5 years or longer...
Nothing else seems loose or anything and the amp has never been jostled around or anything to make anything loose.

Any ideas?


Tue Oct 02, 2012 12:01 am
Profile
Viking Kong
User avatar

Joined: Wed Jan 25, 2006 11:07 pm
Posts: 5559
Location: Bra-silk
Post Re: Laney VC15 losing volume help
I don't even own a tube amp, but I'd say leaving it on for four days made the tubes wear out pretty quick..

_________________
Image
JeffMartin wrote:
Incredibly cool artwork.
You're hired. :)
For what...I have no clue.


Tue Oct 02, 2012 2:51 am
Profile YIM
Unt! I'm a Moderator.

Joined: Sun Jan 30, 2005 8:07 am
Posts: 7453
Post Re: Laney VC15 losing volume help
This place is definitely the wrong person to ask. All the amp-experts disappeared out of nowhere :/


Tue Oct 02, 2012 9:08 am
Profile
Motorman
User avatar

Joined: Sun Oct 19, 2008 9:28 pm
Posts: 410
Location: Odense, Denmark.
Post Re: Laney VC15 losing volume help
Sounds like it needs new tubes. Try new preamp tubes first, they are way cheaper than power tubes and you can change them yourself.
If you use it regularly it isn't unusual that it needs new preamp tubes after a year or so. :)

_________________
- Oliver

Fender HH Tele / RG7321 / Gunslinger -> Pitchblack -> BYOC Wah -> DOD FX25B -> Phase100 -> Xotic EP Booster -> Xotic BB Preamp -> Eventide TimeFactor -> Carvin X100B -> Dr.Z Air Brake -> Orange 2x12


Tue Oct 02, 2012 3:09 pm
Profile
Viking Kong
User avatar

Joined: Fri Feb 18, 2005 6:46 pm
Posts: 5489
Location: Torrance California
Post Re: Laney VC15 losing volume help
I suspect its the tubes as well.


Look for anything obvious. Look at all the preamp tubes and see if one looks noticable different than another.

Ive had preamp tubes lose their vaccum so the silver stuff at the top of the tube turned white.

_________________
Image


Tue Oct 02, 2012 5:31 pm
Profile
Viking Kong
User avatar

Joined: Sat Jan 13, 2007 7:37 pm
Posts: 5165
Location: London
Post Re: Laney VC15 losing volume help
Pre-amp tubes probably need replacing. Any idea what the colouration on them is? Or if they look different at all?

_________________
Thanks MDucran


Wed Oct 03, 2012 5:32 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.